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Although there is no distinctive header, this is the abstract. The template allows authors to format their papers for submission to an ACM Conference or a Journal. The ACM manuscript template is a single column document that allows authors to type their content into the pre-existing set of formatting styles, applied to the sample placeholder text here. Throughout the document, you will find further instructions on how to format your text.
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First Author’ Name, Initials, and Last Name, Second Author’ Name, Initials, and Last Name, and Third Author’ Name, Initials, and Last Name. 2021. The Title of the Paper. In ICCTA 2021: 7th International Conference on Computer Technology Applications, July 13-15, 2021, Vienna, Austria. ACM, New York, NY, USA, XX pages. https://doi.org/ (the doi information will be completed after uploading copyright).
Introduction
ACM's manuscript submission template aims to provide consistent styles for use across ACM publications, and incorporates metadata necessary for Digital Library endeavors. Numerous ACM and SIG-specific templates have been examined, and their unique features incorporated into this template.
The ACM “Submission Template” is a single column MS-Word document that allows authors to write their content into the pre-existing set of formatting styles on the sample of placeholder text here, or copy-and-paste their text and then apply the respective paragraph styles (Windows: you can open the Styles task pane from the Home tab [it can also be opened with the keyboard shortcut Alt+Ctrl+Shift+S]; MAC16: you can access the Styles pane at the right of the Home toolbar.) Highlight a section that you want to designate with a certain style, and then select the appropriate style from the list. To view which style is being used in any part of this document, place your cursor on your text and look at the “Current style” field in the Styles pane.
It is beneficial to create your document in draft mode with the style panel open in the left-side panel. If the panel is not immediately visible when the Submission Template is opened, you will need to open the panel manually—for Windows: click on the following from the main ribbon above: File > Options > Advanced > Display > Style area pane width in Draft and Outline views. 
All style elements are specified in this template to facilitate the production of your paper. The paragraph styles examples are provided throughout this document. Save and backup your work regularly!
Accessibility
Following the guidelines throughout this template will also improve the accessibility of your manuscript and increase the audience for your work.  Ensure that heading styles are applied as instructed, tables are created using Word’s table feature (rather than an image), figures have a description text, and list styles are applied.
To increase the accessibility of your manuscript, you may set the title and language metadata. On Word for Windows, open the File tab and click on Info. On Word for Mac, click the File Menu and select Properties, then click the Summary tab. Fill in the title of your document. For anonymous review, clear the ‘author’ field.
To set the document language, click the Review tab in the Ribbon. On Word for Windows: Click the Language button and select “Set Proofing Language.” Verify the language is set correctly. On Word for Mac: Click the Language button and select the document language from the pop-up.
More about the submission template
This submission version of your paper should remain in a one-column format, please do not alter any of the styles or margins.
If a paper is accepted for publication, authors will be instructed on the next steps. Authors must then follow the submission instructions. 
Inserting CCS concepts
The template enables you to import required indexing concepts for your article from the ACM Computing Classification System (CCS) using an indexing support tool found in the ACM Digital Library (DL). The tool generates formatted text after you have selected your terms. To insert CCS terms into your document, copy and paste the formatted text from the CCS tool using the “https://dl.acm.org/ccs/ccs.cfm” link into the “CCS CONCEPTS” section. 
An additional step is necessary to ensure that the proper CCS terms are added to the Digital Library citation page: from the “view CCS TeX Code” listing, click on “Show the XML Only.” Highlight and copy the XML code from the window. You must insert the XML code into your Word document’s properties: from your Word document, click on “File”, then click on the “Info” tab on the left-hand side panel, then click “Properties” and select “Show All Properties.” Click within the “Comments” metadata field and paste the XML data.
Inserting Content Elements
The next subsections provide instructions on how to insert figures, tables, and equations in your document. 
Tables
Tables should be inserted after their first text reference. Authors can insert tables by using the MS Word option (INSERT ->Table) and providing the required row and column size. Every table must have a caption (title) above it, which must have the “TableCaption” style applied. As an example, Table 1 shows the styles available in this template, to be applied to the respective element of your text. 
[bookmark: _Ref31715975]Table 1: Styles available in the Word template
	Style Tag
	Definition
	Style Tag
	Definition

	Title_document
	the main title of the article
	ListParagraph
	list items

	Subtitle
	subtitle of article
	Statements
	math statements

	Authors
	author name
	Extract
	block quotations

	Affiliation
	author affiliation information
	Algorithm Caption
	caption for algorithm

	AuthNotes
	footnote to author(s)
	AckHead
	heading for acknowledgements

	Abstract
	abstract text
	AckPara
	acknowledgements text

	CCSHead
	heading for CSS Concepts
	GrantSponsor
	sponsor of grant

	CCSDescription
	CSS terms
	GrantNumber
	number for the grant

	KeyWordHead
	heading for keywords
	ReferenceHead
	heading for references

	Keywords
	keywords text
	Bib_entry
	references

	ORCID
	author's ORCHID #
	AppendixH1
	appendix heading level 1

	Head1
	heading level 1
	AppendixH2
	appendix heading level 2

	Head2
	heading level 2
	AppendixH3
	appendix heading level 3

	Head3
	heading level 3
	TableCaption
	title of table

	PosHeadPara
	first paragraph after a heading
	TableHead
TableFootnote
	column head of table
footnote to table

	Para
	Subsequent paragraphs of general text
	Image
	figures

	ParaContinue

DisplayFormula
	flush left text after display items like math equations, lists etc.
numbered math equation
	DOI
	Digital object identifier

	DisplayFormulaUnnum
	unnumbered equations
	Label
	label



A key to making data tables readable is to identify column and row headers. Below are the steps to do this:
Select that table’s row, then right-click the row and select “Table Properties”;
In the Table Properties window, click the Row tab and select the box that says “Repeat as header row at the top of each page.”
Or
Apply the “table head” style by highlighting the respective row and applying the “TableHead” style found in the “Body Element” section of the ACM Template.
Figures
Figures should be inserted after their first text reference. Insert a figure and apply the “Image” style to it. For the figure caption, apply the style “FigureCaption.” 
To accommodate color vision differences, figures should still be usable when printed in grayscale. Refer to elements of the figure with non-color terms, for example “indicated as squares” instead of “indicated in blue”. Use different patterns in bar charts, different line patterns in graphs, and different shapes in plots to distinguish groups of elements and reinforce color differences.
Half Width Figures.
Figure 1 is an example of a figure and caption spanning the half-page width.  If your figure contains third-party material, you must clearly identify it as such, as shown in the example below.
[image: C:\Dropbox\in\downloads\sample-franklin.png]
Figure 1: 1907 Franklin Model D roadster. Photograph by Harris & Ewing,
Inc. [Public domain], via Wikimedia Commons. (https://goo.gl/VLCRBB)
Full Width Figures.
Figure 2 is an example of a figure and caption spanning the full-page width with the styles applied. If your figure contains third-party material, you must clearly identify it as such, as shown in the example.
[image: C:\Dropbox\in\downloads\sample-franklin.png]
Figure 2: Mockup of a bombe machine at Bletchley Part. Photograph by Sarah Hartwell. [Public domain], via Wikimedia Commons. (https://commons.wikimedia.org/wiki/File:TuringBombeBletchleyPark.jpg)
Figure Descriptions.
Every figure should have a description. Figure descriptions should not repeat the figure caption – their purpose is to capture important information that is not provided in the caption. For figures that convey important information, a short plain text description may not be adequate. More complex alternative descriptions can be placed in an appendix and referenced in a short figure description. For example, provide a data table capturing the information in a bar chart, or a structured list representing a graph.  For additional information regarding how best to write figure descriptions, please see https://www.acm.org/accessibility.
Quotations and Extracts
There are styles for block quotations, which should be used for quotes that are separated from in-line text.  Below is an example.
“Microsoft tried to revive the idea of an assistant with Clippy, who began popping up in Microsoft Office in 1997.  Its creator, Kevan Atteberry, was actually contracted by Microsoft to design Clippy, which, funnily enough, he did on a Mac …  Sure, people could disable Clippy, but the fact he was on by default angered people.” [10] 
Equations
There are two types of math equations: the numbered display math equation and the un-numbered display math equation. Below are examples of both.
DisplayFormula.
The DisplayFormula style is applied in the numbered math equation. A numbered display equation always has an equation number (label) on the right.
	(1)
DisplayFormula.Unnum.
The DisplayFormulaUnnum style is applied only in unnumbered equations. An unnumbered display equation does not contains an equation number on the right. 

Please note: the subsequent text after the DisplayFormula (numbered equation) or DisplayFormulaUnnum (unnumbered equation) must have the paragraph style ParaContinue applied.
Math statements
Math statements should have the “Statement” style applied.
Theorem/Proof/Lemma. Math statements should have the “Statement” style applied. This paragraph is an example of the “Statement” style.
Algorithms
Algorithms use the styles “AlgorithmCaption” and “Algorithm”.
ALGORITHM 1: Iterative Algorithm
current_position  	 center
current_direction  	 up
current_position  is inside circle
while current_position is inside circle, do
	neighborhood all grid hexes within two hexes from current_position
	for each hex in neighborhood, do 
		for each neuron in hex do
		      convert neuron_orientation to vector
		      scale vector by neuron_excitation
	            vector_sum vector_sum + vector
             end 
      end
     normalize vector_sum
end
Citing Related Work
This section gives examples of citations of the journals [5, 15], conferences [1, 6, 8, 12, 13], and a magazine [3] to illustrate how they appear in the main text section. It also cites books [9, 10], a technical report [7], a PhD dissertation [4], an online reference [14], a software artifact [11], and a dataset [2].
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A  APPENDICES
In the appendix section, three levels of Appendix headings are available.
A.1 General Guidelines (AppendixH2)
Equations should be created with the built-in MS Word Microsoft® Equation Editor or MathType. 
Tables should be created with Word’s “Insert Table” tool.
Footnotes should be inserted using Word’s “Insert Footnote” feature.
Please save all files in DOCX format. 
Save and backup your file regularly.
A.1.1 Preparing Graphics (AppendixH3)
1. Accepted image file formats: TIFF (.tif), JPEG (.jpg).
2. Scalable vector formats (i.e., SVG, EPS and PS). 
3. Application files (e.g., Corel Draw, MS Word, MS Excel, PPT, etc.) are NOT recommended.
4. Images created in Microsoft Word using text-box, shapes, clip-art are NOT recommended.
5. IMPORTANT: All fonts must be embedded in your figure files.
6. Set the correct orientation for each graphics file.
A.2 Placeholder Text
Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Vulputate sapien nec sagittis aliquam. Malesuada fames ac turpis egestas sed tempus urna. Posuere sollicitudin aliquam ultrices sagittis orci. Consequat id porta nibh venenatis cras sed felis eget. Pellentesque eu tincidunt tortor aliquam nulla facilisi cras fermentum odio. Tincidunt nunc pulvinar sapien et ligula ullamcorper malesuada proin. Tincidunt lobortis feugiat vivamus at augue. Eget nunc lobortis mattis aliquam faucibus. Egestas diam in arcu cursus euismod quis.
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